Building Qgis with MSYS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Building Qgis with MSYS

whatnick-2
Hi,

I usually make the MSYS release builds. I use the recommended CVS
branches and stable releases for all dependencies. I use GDAL CVS and
Grass CVS 6.3RC3 tags. There are some issues with GDAL support on MINGW
so the little 'sed' line hacks the libtool to work properly. Please let
me know if you need help with any particular steps.

Regards,

Tishampati Dhar

 Remote Sensing Software Developer

 APOGEE IMAGING INTERNATIONAL

 Building 12B

 1 Adelaide - Lobethal Road

 Lobethal SA 5241

  Telephone: +61 - 8 - 8389 5499

 Fax: +61 - 8 - 8389 5488

 Mobile: +61 - 406114165

Email: [hidden email] mailto:[hidden email]>

Web: www.apogee.com.au <http://www.apogee.com.au>

 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

"The information in this e-mail may be confidential and/or commercially
privileged. It is intended solely for the addressee. Access to this
e-mail by anyone else is unauthorised. If you are not the
intendedrecipient, any disclosure, copying, distribution or action taken
or omitted to be taken in reliance on it, is prohibited and may be
unlawful."
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Building Qgis with MSYS

Magnus Homann
Tisham Dhar wrote:
> Hi,
>
> I usually make the MSYS release builds. I use the recommended CVS
> branches and stable releases for all dependencies. I use GDAL CVS and
> Grass CVS 6.3RC3 tags. There are some issues with GDAL support on MINGW
> so the little 'sed' line hacks the libtool to work properly. Please let
> me know if you need help with any particular steps.

I build with cygwin and the old msys that timliunx suppplied. No hack
necessary. Is there a reason for me to build in any other way?

--
Magnus Homann

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

R: Building Qgis with MSYS

Marco Pasetti-2
In reply to this post by whatnick-2
Hi Tisham,
 
Thanks for your reply.
I'm making a new clean install/building of MSYS enviroment.
 
I'm using Paul Kelly's precompiled libraries for GRASS (from http://www.stjohnspoint.co.uk/grass/wingrass-extralibs.tar.gz)
 
I'm applying instructions in 6.2.2 of the wiki. I built GDAL using instructions in the wiki (I made a build-gdal.sh, attached). After building I noticed no errors but some warnings and a list of strange "Nothing to do" messages I copied in build-gdal.log.txt.
 
After that I edited gdal-config with:
CONFIG_LIBS="-L/usr/local/lib -lpng -lz -lgdal"
Now I'm at the following instructions:

[From the wiki]: GDAL build procedure can be greatly simplified to use libtool with a libtool line patch [....]

That I intended as follow: in /usr/local/src/gdal-1.4.1/ type

./configure --with-ngpython --with-xerces=/local/ --with-jasper=/local/ --with-grass=/local/grass-6.3.cvs/ --with-pg=/local/pgsql/bin/pg_config.exe

and then type:

mv libtool libtool.orig cat libtool.orig | sed 's/max_cmd_len=8192/max_cmd_len=32768/g' > libtool

is that right? Waiting for your answer, I'll type them in the shell... hoping to not need to redo everything because of wrong commands!

Regards,

Marco



Da: Tisham Dhar [mailto:[hidden email]]
Inviato: ven 18/01/2008 4.16
A: [hidden email]
Cc: [hidden email]
Oggetto: Building Qgis with MSYS

Hi,

I usually make the MSYS release builds. I use the recommended CVS
branches and stable releases for all dependencies. I use GDAL CVS and
Grass CVS 6.3RC3 tags. There are some issues with GDAL support on MINGW
so the little 'sed' line hacks the libtool to work properly. Please let
me know if you need help with any particular steps.

Regards,

Tishampati Dhar

 Remote Sensing Software Developer

 APOGEE IMAGING INTERNATIONAL

 Building 12B

 1 Adelaide - Lobethal Road

 Lobethal SA 5241

  Telephone: +61 - 8 - 8389 5499

 Fax: +61 - 8 - 8389 5488

 Mobile: +61 - 406114165

Email: [hidden email]
[hidden email]>

Web: www.apogee.com.au <
http://www.apogee.com.au>

 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

"The information in this e-mail may be confidential and/or commercially
privileged. It is intended solely for the addressee. Access to this
e-mail by anyone else is unauthorised. If you are not the
intendedrecipient, any disclosure, copying, distribution or action taken
or omitted to be taken in reliance on it, is prohibited and may be
unlawful."


_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer

build-gdal.sh (2K) Download Attachment
build-gdal.log.txt (17K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

R: Building Qgis with MSYS

Marco Pasetti-2
In reply to this post by whatnick-2
Hi Tisham,
 
I made as follows:
 
[hidden email] /usr/local/src/gdal-1.4.1
$ configure gdal as below: ./configure --with-ngpython --with-xerces=/local/ --with-jasper=/local/ --with-grass=/local/grass-6.3.cvs/ --with-pg=/local/pgsql/bin/pg_config.exe
 
It returned an error because (I think) I did not installed PostgreSQL (the wiki doesn't tell to install it). Attached the logfile.
 
And then:
 
[hidden email] /usr/local/src/gdal-1.4.1
$ fix-libtool.sh
mv: when moving multiple files, last argument must be a directory
Try `mv --help' for more information.
 
????????
 
Thanks,
 
Marco

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer

configure-gdal.log.txt (8K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Building Qgis with MSYS

Marco Pasetti-2
In reply to this post by whatnick-2
Hi Tisham,
 
about what you said in the last mail: " I use GDAL CVS and Grass CVS 6.3RC3 tags "
 
1. About GDAL CVS:
 
I built gdal 1.4.1 and patched libtool; now I'll try to build 1.5.0 version (latest stable release) with the same patch instructions found in the wiki;
 
2. About GRASS CVS:
 
You suggested to use GRASS 6.3RC3 CVS source code, but I never used CVS system; is it the same if I use RC3 package found here:
 
Thanks for your help. Regards,
 
Marco

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Building Qgis with MSYS

Marco Pasetti-2
In reply to this post by whatnick-2
Hi Tisham,
 
1. GDAL: I built gdal 1.5.0.... it's really a mess! I'll be back with 1.4.1
 
2. GRASS Source Code: now I'm rebuilding GDAL 1.4.1 (it takes a while)... later I'll build GRASS from RC03 source code, and then I'll try with RC04; it's the latest release candidate, so I guess it works good as RC03; I downloaded both from http://download.osgeo.org/grass/grass63/source/
 
Thanks. Regards,
 
Marco

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer