Building QGIS From Source Under Windows Using MSYS

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Building QGIS From Source Under Windows Using MSYS

Marco Pasetti-2

Hello,

I want to build QGIS under windows; I started reading in the QGIS wiki about compilation (BuildingFromSource document)http://wiki.qgis.org/qgiswiki/BuildingFromSource

After reading introduction and building notes, I jumped to section

3. Building under windows using msys

in this section I read in 3.1 that I can use a pre-built MSYS enviroment with all dependencies, or create it by myself one following the instructions detailed in section 6; because i want to build a new GRASS module I decided for the last.

QUESTION: After completing instructions in section 6, I have to follow section 3, starting from 3.2. Is that right?

6. Creation of MSYS environment for compilation of Quantum GIS

6.1. Initial setup

I exactly followed instructions detailed in section 6.1; about that I would remark:

http://puzzle.dl.sourceforge.net/sourceforge/mingw/MSYS-1.0.11-2004.04.30-1.exe link is dead!

I used instead: http://prdownloads.sourceforge.net/mingw/MSYS-1.0.11-2004.04.30-1.exe?download

http://puzzle.dl.sourceforge.net/sourceforge/mingw/MinGW-5.1.3.exe link is dead!

I used instead: http://downloads.sourceforge.net/mingw/MinGW-5.1.3.exe?modtime=1168811236&big_mirror=1

6.2. Installing dependencies

6.2.1. Getting ready

I downloaded Paul Kelly's package of precompiled libraries for GRASS and unpacked in c:\msys\local

6.2.2. GDAL level one

I exactly followed all the instructions, except:

GDAL build procedure can be greatly simplified to use libtool with a libtool line patch: configure gdal as below: ./configure --with-ngpython --with-xerces=/local/ --with-jasper=/local/ --with-grass=/local/grass-6.3.cvs/ --with-pg=/local/pgsql/bin/pg_config.exe

Then fix libtool with: mv libtool libtool.orig cat libtool.orig | sed 's/max_cmd_len=8192/max_cmd_len=32768/g' > libtool

Because I didn't understand well those instructions.

QUESTION: What should I do?

6.2.3. GRASS

I followed all the instructions detailed in this section, using grass-6.3.0RC4 source. After compiling I have the following compilation log:

GRASS GIS compilation log
------------------------------------------------------------------------------------------------------------
Started compilation: Wed Jan 16 17:39:21 GMT 2008
------------------------------------------------------------------------------------------------------------
Errors in:
/usr/local/src/grass-6.3.cvs/imagery/i.class
/usr/local/src/grass-6.3.cvs/imagery/i.ortho.photo/photo.2image
/usr/local/src/grass-6.3.cvs/imagery/i.ortho.photo/photo.2target
/usr/local/src/grass-6.3.cvs/imagery/i.ortho.photo/photo.rectify
/usr/local/src/grass-6.3.cvs/imagery/i.points
/usr/local/src/grass-6.3.cvs/imagery/i.vpoints
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.daemon
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.edgedensity
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.patchdensity
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.patchnum
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.shape
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.simpson
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.shannon
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.mps
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.mpa
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.padcv
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.padsd
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.padrange
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.cwed
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.richness
/usr/local/src/grass-6.3.cvs/raster/r.li/r.li.dominance
/usr/local/src/grass-6.3.cvs/raster/r.terraflow
/usr/local/src/grass-6.3.cvs/visualization/nviz
------------------------------------------------------------------------------------------------------------
In case of errors please change into the directory with error and run 'make'.
If you get multiple errors, you need to deal with them in the order they
appear in the error log. If you get an error building a library, you will
also get errors from anything which uses the library.
------------------------------------------------------------------------------------------------------------
Finished compilation: Wed Jan 16 18:37:48 GMT 2008

QUESTIONS: --------------------------------------------------------------------------------------------------------------------------------------------------------------

1. those errors are dued to not complete execution of instruction in 6.2.2, or should I recompile GRASS libraries by myself?

2. to fix errors should I simply re-apply instructions from 6.2.2, or should I detelete something?
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Thanks for all your help,
 
Marco

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer