BigTiff output invalid - OSSIM Osgeo4W

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

BigTiff output invalid - OSSIM Osgeo4W

GinBijn
Hi all,

I want to orthorectify some Worlview2 images ussim Ossim-orthoigen in the Osgeo4W command shell. It goes well for small files (<1 GB), but I have some scnenes that are larger (approx. 2 GB) and the output cannot be opened (tried in QGis and Gdalinfo). After running ossim-info on the outputs, it seems that the problem is with tiff.version: 43 (big)

I used the osgeo4W 32 bit installer to install all programs ( sorry do not know how to "build").

I suspect this has something to do with the tiff writer. But I cannot find out how to install/download the gdalplugin.

On another note, how do I set the OSSIM_PREFS_FILE environmental variable? Using " set OSSIM_PREFS_FILE <path and file name of prefs>" does not work.

Any tips on how to fix this?

Cheers

-Ginny
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

David Burken
Hi,

We do not control that build.  I sent you a note direct with an
installer you could try.  Let me know how it works.  Here's some links:

http://trac.osgeo.org/ossim/wiki/ossimPreferenceFile
http://trac.osgeo.org/ossim/wiki/ossimElevationSetup
http://trac.osgeo.org/ossim/wiki/ossimPluginSetup

Take care,
Dave

On 1/22/15, 9:01 AM, GinBijn wrote:

> Hi all,
>
> I want to orthorectify some Worlview2 images ussim Ossim-orthoigen in the
> Osgeo4W command shell. It goes well for small files (<1 GB), but I have some
> scnenes that are larger (approx. 2 GB) and the output cannot be opened
> (tried in QGis and Gdalinfo). After running ossim-info on the outputs, it
> seems that the problem is with tiff.version: 43 (big)
>
> I used the osgeo4W 32 bit installer to install all programs ( sorry do not
> know how to "build").
>
> I suspect this has something to do with the tiff writer. But I cannot find
> out how to install/download the gdalplugin.
>
> On another note, how do I set the OSSIM_PREFS_FILE environmental variable?
> Using " set OSSIM_PREFS_FILE <path and file name of prefs>" does not work.
>
> Any tips on how to fix this?
>
> Cheers
>
> -Ginny
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/BigTiff-output-invalid-OSSIM-Osgeo4W-tp5183132.html
> Sent from the Ossim-developer mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
> GigeNET is offering a free month of service with a new server in Ashburn.
> Choose from 2 high performing configs, both with 100TB of bandwidth.
> Higher redundancy.Lower latency.Increased capacity.Completely compliant.
> http://p.sf.net/sfu/gigenet
> _______________________________________________
> www.ossim.org
> Ossim-developer mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer
>


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

GinBijn
I used the installer you sent off list and set up my elevation and prefs.
However, I still run into my original problem. These are my steps

1-create overview
ossim-img2rr P001.til

2-orthorectify
ossim-orthoigen P001.til P001.tif

Now, when I do this for a small scene all goes well. The output image opens up in Qgis. I ran ossim-info -d on a small scene (300mb)


When I do the same for a large scene (2.2gb), I get an 'invalid source' error in Qgis and ossim-info returns this


Does this have something to do with the native tif writer? I also tried using the gdal writer:
ossim-orthoigen -w gdal_gtiff  P001.til P001.tif
But the output was a "file" type eventhough gdalinfo recognized it as geotiff.

Is there some setting I am missing?
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

Garrett Potts-2
Hello:

There is a bug in the std streams on windows that if you don’t compile to the latest Windows compiler then the std::streamoff is only 32 bits.

I wonder though if the tiff library is ok for they go through the c library which should be fine.  Our TiffInfo dump that you see goes through the C++ library and the std::streamoff is only 32 bits


What binary is this from that you are running?

We have not officially upgraded our distribution to the latest compiler but Dave B. has a side project that has most of this done.  To upgrade to the latest Qt5 we have to update the compiler support.


Take care

Garrett

> On Feb 4, 2015, at 7:23 AM, GinBijn <[hidden email]> wrote:
>
> I used the installer you sent off list and set up my elevation and prefs.
> However, I still run into my original problem. These are my steps
>
> 1-create overview
> ossim-img2rr P001.til
>
> 2-orthorectify
> ossim-orthoigen P001.til P001.tif
>
> Now, when I do this for a small scene all goes well. The output image opens
> up in Qgis. I ran ossim-info -d on a small scene (300mb)
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/small_scene.png>
>
> When I do the same for a large scene (2.2gb), I get an 'invalid source'
> error in Qgis and ossim-info returns this
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/big_scene.png>
>
> Does this have something to do with the native tif writer? I also tried
> using the gdal writer:
> ossim-orthoigen -w gdal_gtiff  P001.til P001.tif
> But the output was a "file" type eventhough gdalinfo recognized it as
> geotiff.
>
> Is there some setting I am missing?
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/BigTiff-output-invalid-OSSIM-Osgeo4W-tp5183132p5185452.html
> Sent from the Ossim-developer mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming. The Go Parallel Website,
> sponsored by Intel and developed in partnership with Slashdot Media, is your
> hub for all things parallel software development, from weekly thought
> leadership blogs to news, videos, case studies, tutorials and more. Take a
> look and join the conversation now. http://goparallel.sourceforge.net/
> _______________________________________________
> www.ossim.org
> Ossim-developer mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

David Burken
In reply to this post by GinBijn
Hi,

I'm wondering if it's your Qgis application?

Can you bring the image up in ossim-geocell?  The other way to test the
ossim code would be to do an image copy with "ossim-icp".  When it hits
tiles past 2GB it will error.

Let me know if you can't bring it up in geocell and I will fix it.

Take care,
Dave


On 02/04/2015 07:23 AM, GinBijn wrote:

> I used the installer you sent off list and set up my elevation and prefs.
> However, I still run into my original problem. These are my steps
>
> 1-create overview
> ossim-img2rr P001.til
>
> 2-orthorectify
> ossim-orthoigen P001.til P001.tif
>
> Now, when I do this for a small scene all goes well. The output image opens
> up in Qgis. I ran ossim-info -d on a small scene (300mb)
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/small_scene.png>
>
> When I do the same for a large scene (2.2gb), I get an 'invalid source'
> error in Qgis and ossim-info returns this
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/big_scene.png>
Does this have something to do with the native tif writer? I also tried
using the gdal writer: ossim-orthoigen -w gdal_gtiff P001.til P001.tif
But the output was a "file" type eventhough gdalinfo recognized it as
geotiff. Is there some setting I am missing? -- View this message in
context:
http://osgeo-org.1560.x6.nabble.com/BigTiff-output-invalid-OSSIM-Osgeo4W-tp5183132p5185452.html 
Sent from the Ossim-developer mailing list archive at Nabble.com.
------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is
your hub for all things parallel software development, from weekly
thought leadership blogs to news, videos, case studies, tutorials and
more. Take a look and join the conversation now.
http://goparallel.sourceforge.net/ 
_______________________________________________ www.ossim.org
Ossim-developer mailing list [hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

jratike80
In reply to this post by GinBijn
Hi,

Tell us also what gdalinfo is reporting about your images. If it throws an error, try if "gdalinfo --debug on big.tif" prints some useful information.

-Jukka Rahkonen-

David Burken wrote:

> Hi,

> I'm wondering if it's your Qgis application?

> Can you bring the image up in ossim-geocell?  The other way to test the ossim code would be to do an image copy with "ossim-icp".  When it hits tiles past 2GB it will error.

> Let me know if you can't bring it up in geocell and I will fix it.

> Take care,
> Dave


On 02/04/2015 07:23 AM, GinBijn wrote:

> I used the installer you sent off list and set up my elevation and prefs.
> However, I still run into my original problem. These are my steps
>
> 1-create overview
> ossim-img2rr P001.til
>
> 2-orthorectify
> ossim-orthoigen P001.til P001.tif
>
> Now, when I do this for a small scene all goes well. The output image
> opens up in Qgis. I ran ossim-info -d on a small scene (300mb)
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/small_scene.png>
>
> When I do the same for a large scene (2.2gb), I get an 'invalid source'
> error in Qgis and ossim-info returns this
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/big_scene.png>
Does this have something to do with the native tif writer? I also tried using the gdal writer: ossim-orthoigen -w gdal_gtiff P001.til P001.tif But the output was a "file" type eventhough gdalinfo recognized it as geotiff. Is there some setting I am missing? -- View this message in
context:
http://osgeo-org.1560.x6.nabble.com/BigTiff-output-invalid-OSSIM-Osgeo4W-tp5183132p5185452.html
Sent from the Ossim-developer mailing list archive at Nabble.com.
------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website, sponsored by Intel and developed in partnership with Slashdot Media, is your hub for all things parallel software development, from weekly thought leadership blogs to news, videos, case studies, tutorials and more. Take a look and join the conversation now.
http://goparallel.sourceforge.net/
_______________________________________________ www.ossim.org Ossim-developer mailing list [hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer


------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website, sponsored by Intel and developed in partnership with Slashdot Media, is your hub for all things parallel software development, from weekly thought leadership blogs to news, videos, case studies, tutorials and more. Take a look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer

------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

David Burken
Hi Jukka,

I just duplicate the issue. It's an ossim build problem.  Fixing now...

Take care,
Dave

On 2/4/2015 8:44 AM, Rahkonen Jukka (MML) wrote:

> Hi,
>
> Tell us also what gdalinfo is reporting about your images. If it throws an error, try if "gdalinfo --debug on big.tif" prints some useful information.
>
> -Jukka Rahkonen-
>
> David Burken wrote:
>
>> Hi,
>> I'm wondering if it's your Qgis application?
>> Can you bring the image up in ossim-geocell?  The other way to test the ossim code would be to do an image copy with "ossim-icp".  When it hits tiles past 2GB it will error.
>> Let me know if you can't bring it up in geocell and I will fix it.
>> Take care,
>> Dave
>
> On 02/04/2015 07:23 AM, GinBijn wrote:
>> I used the installer you sent off list and set up my elevation and prefs.
>> However, I still run into my original problem. These are my steps
>>
>> 1-create overview
>> ossim-img2rr P001.til
>>
>> 2-orthorectify
>> ossim-orthoigen P001.til P001.tif
>>
>> Now, when I do this for a small scene all goes well. The output image
>> opens up in Qgis. I ran ossim-info -d on a small scene (300mb)
>> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/small_scene.png>
>>
>> When I do the same for a large scene (2.2gb), I get an 'invalid source'
>> error in Qgis and ossim-info returns this
>> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/big_scene.png>
> Does this have something to do with the native tif writer? I also tried using the gdal writer: ossim-orthoigen -w gdal_gtiff P001.til P001.tif But the output was a "file" type eventhough gdalinfo recognized it as geotiff. Is there some setting I am missing? -- View this message in
> context:
> http://osgeo-org.1560.x6.nabble.com/BigTiff-output-invalid-OSSIM-Osgeo4W-tp5183132p5185452.html
> Sent from the Ossim-developer mailing list archive at Nabble.com.
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming. The Go Parallel Website, sponsored by Intel and developed in partnership with Slashdot Media, is your hub for all things parallel software development, from weekly thought leadership blogs to news, videos, case studies, tutorials and more. Take a look and join the conversation now.
> http://goparallel.sourceforge.net/
> _______________________________________________ www.ossim.org Ossim-developer mailing list [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer
>
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming. The Go Parallel Website, sponsored by Intel and developed in partnership with Slashdot Media, is your hub for all things parallel software development, from weekly thought leadership blogs to news, videos, case studies, tutorials and more. Take a look and join the conversation now. http://goparallel.sourceforge.net/
> _______________________________________________
> www.ossim.org
> Ossim-developer mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming. The Go Parallel Website,
> sponsored by Intel and developed in partnership with Slashdot Media, is your
> hub for all things parallel software development, from weekly thought
> leadership blogs to news, videos, case studies, tutorials and more. Take a
> look and join the conversation now. http://goparallel.sourceforge.net/
> _______________________________________________
> www.ossim.org
> Ossim-developer mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer
>


------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer
Reply | Threaded
Open this post in threaded view
|

Re: BigTiff output invalid - OSSIM Osgeo4W

David Burken
In reply to this post by GinBijn
Hi Ginny,

I think this one works.  Wrote out an 8Gb tiff with ossim-chipper and
viewed in ossim-geocell.  Let me know.

http://download.osgeo.org/ossim/installers/windows/ossim-osgeo_x64_1_8_19-20150219-1.exe

Take care,
Dave

On 02/04/2015 07:23 AM, GinBijn wrote:

> I used the installer you sent off list and set up my elevation and prefs.
> However, I still run into my original problem. These are my steps
>
> 1-create overview
> ossim-img2rr P001.til
>
> 2-orthorectify
> ossim-orthoigen P001.til P001.tif
>
> Now, when I do this for a small scene all goes well. The output image opens
> up in Qgis. I ran ossim-info -d on a small scene (300mb)
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/small_scene.png>
>
> When I do the same for a large scene (2.2gb), I get an 'invalid source'
> error in Qgis and ossim-info returns this
> <http://osgeo-org.1560.x6.nabble.com/file/n5185452/big_scene.png>
>
> Does this have something to do with the native tif writer? I also tried
> using the gdal writer:
> ossim-orthoigen -w gdal_gtiff  P001.til P001.tif
> But the output was a "file" type eventhough gdalinfo recognized it as
> geotiff.
>
> Is there some setting I am missing?
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/BigTiff-output-invalid-OSSIM-Osgeo4W-tp5183132p5185452.html
> Sent from the Ossim-developer mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Dive into the World of Parallel Programming. The Go Parallel Website,
> sponsored by Intel and developed in partnership with Slashdot Media, is your
> hub for all things parallel software development, from weekly thought
> leadership blogs to news, videos, case studies, tutorials and more. Take a
> look and join the conversation now. http://goparallel.sourceforge.net/
> _______________________________________________
> www.ossim.org
> Ossim-developer mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/ossim-developer
>


------------------------------------------------------------------------------
Download BIRT iHub F-Type - The Free Enterprise-Grade BIRT Server
from Actuate! Instantly Supercharge Your Business Reports and Dashboards
with Interactivity, Sharing, Native Excel Exports, App Integration & more
Get technology previously reserved for billion-dollar corporations, FREE
http://pubads.g.doubleclick.net/gampad/clk?id=190641631&iu=/4140/ostg.clktrk
_______________________________________________
www.ossim.org
Ossim-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/ossim-developer