Associated Resources not displaying

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Associated Resources not displaying

pctan
Hi Jose,

I really need help desperately.


  1.  I installed 3.4.2.war


  1.  I copied iso19139.anzlic plugin from here to schema-plugins folder
https://github.com/metadata101/iso19139.anzlic

Question:
Where do I add this: src/main/resources/config-spring-geonetwork.xml<https://github.com/metadata101/iso19139.anzlic/commit/8017c3b3399105d18a617815660cae7ea20403b0#diff-efa483686f42a79ef50333db5c3ae74a>?

@@ -5,5 +5,5 @@


     xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd<http://www.springframework.org/schema/beans%20http:/www.springframework.org/schema/beans/spring-beans.xsd>">



   <bean id="iso19139ANZLICSchemaPlugin"


-        class="org.fao.geonet.schema.iso19139anzlic.ISO19139ANZLICSchemaPlugin"/>


+        class="org.fao.geonet.schema.iso19139.ISO19139SchemaPlugin"/>


</beans>




  1.  I have problem with iso19139.anzlic plugin.

If a record has schemaid = ‘iso19139.anzlic’, in edit mode, it does not  show the ‘Associated Resources’ for me to attach a parent.


  1.  If a record has schemaid = ‘iso19139’, ‘Associated Resources’ is present.
  2.  Please see the screenshots in the WORD document to make what I am trying to say clearer.



Is there anything else I need to add to make the iso19139.anzlic to show ‘‘Associated Resources’ in edit mode?

Any help/lead will be much appreciated.
Thanks.
Peck


-----------------------------------------------------------------------------------------------------
Peck Choo Tan I Analyst Programmer
GNS Science I Te Pῡ Ao
1 Fairway Drive, Avalon 5010, PO Box 30368, Lower Hutt 5040, New Zealand
Ph 04 570 4739 I Mob 021 2178684
http://www.gns.cri.nz/ | Email: [hidden email]


Notice: This email and any attachments are confidential and may not be used, published or redistributed without the prior written consent of the Institute of Geological and Nuclear Sciences Limited (GNS Science). If received in error please destroy and immediately notify GNS Science. Do not copy or disclose the contents.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

AssocResources.docx (465K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Associated Resources not displaying

raean
I am having the same issue with the loss of my Associating resources panel
recently as well, when moving from 3.02 to 3.42. I have yet to resolve it.

However I do have some clues in 3.02 the editor could be configured by
pasting a snippet of json code in a field under settings metadata
configuration > metadata editor  configuration. e.g. This is the setup I
used for 3.0.2

For example
{"iso19110":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"readonly":true,"categories":["dataset"]},"validation":{"display":true}},"iso19139":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"categories":[]},"suggestion":{"display":true},"validation":{"display":true}},"dublin-core":{"defaultTab":"default","related":{"display":true,"readonly":false,"categories":["parent","onlinesrc"]}},"iso19115-3":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"categories":[]},"suggestion":{"display":true},"validation":{"display":true}},"iso19139.anzlic":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"categories":disp[]},"suggestion":{"display":true},"validation":{"display":true}}}

In the snippet of code you can see the various flags for switching things
off and on. Unfortunately I can no longer find it in 3.4.2 maybe it has
moved else where. I had a look under the editor application settings in user
interface settings to no luck. once this snippet is stored in the right
place it may fix the problem of configuring the editor for different schema.




--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Associated Resources not displaying

pctan
Hi Andrew,

This is Jose's answer to me regarding the same problem:
-------------
In 3.4.2 were done some changes in the way the side panel is configured, previously was used a setting in the database, but now is configured in the config-editor.xml, see https://github.com/geonetwork/core-geonetwork/blob/3.4.x/schemas/iso19139/src/main/plugin/iso19139/layout/config-editor.xml#L3076-L3085
You need to add that snippet in the views of your schema config-editor.xml
------------
Thanks.
Peck

-----Original Message-----
From: raean [mailto:[hidden email]]
Sent: Friday, 20 July 2018 9:53 PM
To: [hidden email]
Subject: Re: [GeoNetwork-users] Associated Resources not displaying

I am having the same issue with the loss of my Associating resources panel recently as well, when moving from 3.02 to 3.42. I have yet to resolve it.

However I do have some clues in 3.02 the editor could be configured by pasting a snippet of json code in a field under settings metadata configuration > metadata editor  configuration. e.g. This is the setup I used for 3.0.2

For example
{"iso19110":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"readonly":true,"categories":["dataset"]},"validation":{"display":true}},"iso19139":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"categories":[]},"suggestion":{"display":true},"validation":{"display":true}},"dublin-core":{"defaultTab":"default","related":{"display":true,"readonly":false,"categories":["parent","onlinesrc"]}},"iso19115-3":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"categories":[]},"suggestion":{"display":true},"validation":{"display":true}},"iso19139.anzlic":{"defaultTab":"default","displayToolTip":false,"related":{"display":true,"categories":disp[]},"suggestion":{"display":true},"validation":{"display":true}}}

In the snippet of code you can see the various flags for switching things off and on. Unfortunately I can no longer find it in 3.4.2 maybe it has moved else where. I had a look under the editor application settings in user interface settings to no luck. once this snippet is stored in the right place it may fix the problem of configuring the editor for different schema.




--
Sent from: http://osgeo-org.1560.x6.nabble.com/GeoNetwork-users-f3860293.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most engaging tech sites, Slashdot.org! http://sdm.link/slashdot _______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Notice: This email and any attachments are confidential and may not be used, published or redistributed without the prior written consent of the Institute of Geological and Nuclear Sciences Limited (GNS Science). If received in error please destroy and immediately notify GNS Science. Do not copy or disclose the contents.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork