Antw: FeatureInfo und Ausgabeformat

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Antw: FeatureInfo und Ausgabeformat

Ronald Woita
So noch ein Versuch.
Ich habe den Eintrag 'WMS_FEATURE_INFO_MIME_TYPE" "text/html"
im WEB-Objekt auf MAP-Ebene, nicht im WEB-Objekt des LAYER.
Vielleicht hilft das ?

Grüße

Ronald



--
Ronald Woita
Hansestadt Rostock
Kataster-, Vermessungs- und Liegenschaftsamt
Holbeinplatz 14, 18069 Rostock
email: [hidden email]
phone: +49 (0)381 - 381 6256

>>> [hidden email] 21.09.2005 10:56 >>>

Hallo Leute!

Ich habe jetzt schon in der User-List etwas rumgestöbert.
Bin aber nicht wirklich weitergekommen.

Ich habe einen Layer den ich gerne Abfragen möchte.

WEB
        IMAGEPATH "C:\Apache2\htdocs\temp\"
        IMAGEURL "http://localhost/temp/"
        METADATA
            WMS_SRS "EPSG:31493"
            WMS_ONLINERESOURCE "http://localhost/...."
            WMS_TITLE "Demo"
        END
END

Layer
        NAME "Strasse"
    STATUS ON
        CONNECTIONTYPE postgis
        CONNECTION "user=user password=password dbname=datenbank
host=localhost"
        DATA "the_geom from strassen"
        DUMP TRUE
        TYPE LINE
        TOLERANCE 5
    TOLERANCEUNITS PIXELS
    SIZEUNITS PIXELS

        TOLERANCE 10
        TEMPLATE "C:/daten/templates/query_strassen.html"
    HEADER "C:/daten/templates/header_strassen.html"
    FOOTER "C:/daten/templates/footer_strassen.html"
                       
    METADATA
      "WMS_SRS"    "epsg:31493"
      "WMS_TITLE"  "Strassen"
                "WMS_FEATURE_INFO_MIME_TYPE" "text/html"
    END
        PROJECTION
      "init=epsg:31493"
        END
   
        CLASS
                NAME "Strassen"
                OUTLINECOLOR 128 128 128
        END
END


Wenn ich das jetzt durchführe, also ein FeatureInfo bekomme ich als
ergebnis folgendes:

 Die XML-Seite kann nicht angezeigt werden
Die XML-Eingabe kann nicht angezeigt werden, wenn Stylesheet verwendet
 wird.
Beheben Sie den Fehler und klicken Sie dann auf Aktualisieren, oder
 wiederholen
 Sie den Vorgang spter.

Ungltig auf der obersten Ebene im Dokument. Fehler beim Bearbeiten der
 Ressource
 'http://localhost/cgi-bin/mapserv_46.exe?...

 Content-type: application/vnd.ogc.se_xml


In der WMS-Einstellung habe ich als Ausgabeformat text/html eingestellt.
Jemand eine Idee??


Viele Grüße

(P.S.: Mapserver Version 4.6.1)



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php 
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

Re: Antw: FeatureInfo und Ausgabeformat

Jens Siffermann

Guter Tip, aber noch ne enttäuschung. Hab ich ausprobiert.
Gleiche Effekt. Ich hab das ganze mal mit dem Mapserver Version 4.0
getestet. Da klappt es wurderbar. Allerdings kann der noch keine
Legende erstellen. Wenn ich mir text/plain aus geben lasse,
funktioniert es mit jeder Version.

Gruß


Jens

Am Mi 21.09.2005 14:22 schrieb Ronald Woita <[hidden email]>:

> So noch ein Versuch.
> Ich habe den Eintrag 'WMS_FEATURE_INFO_MIME_TYPE" "text/html"
> im WEB-Objekt auf MAP-Ebene, nicht im WEB-Objekt des LAYER.
> Vielleicht hilft das ?
>
> Grüße
>
> Ronald
>
>
>
> --
> Ronald Woita
> Hansestadt Rostock
> Kataster-, Vermessungs- und Liegenschaftsamt
> Holbeinplatz 14, 18069 Rostock
> email: [hidden email]
> phone: +49 (0)381 - 381 6256
>





-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

Re: Re: Antw: FeatureInfo und Ausgabeformat

Jens Siffermann

OK, OK! Ich zieh mir selber die Ohren lang!!

Ganz einfach. Hat weder was mit Mapbender noch mit Mapserver
was zu tun.


Stichwort: BUG 736 http://mapserver.gis.umn.edu/bugs/show_bug.cgi?id=736


Man sollte halt den Pfad zum Template richtig angeben!!!! Dann
funktionierts wunderbar. Tun mir leid, wenn ich eure Zeit gestohlen
habe!


Gruß

Jens




Am Mi 21.09.2005 14:45 schrieb Jens Siffermann
<[hidden email]>:

>
> Guter Tip, aber noch ne enttäuschung. Hab ich ausprobiert.
> Gleiche Effekt. Ich hab das ganze mal mit dem Mapserver Version 4.0
> getestet. Da klappt es wurderbar. Allerdings kann der noch keine
> Legende erstellen. Wenn ich mir text/plain aus geben lasse,
> funktioniert es mit jeder Version.
>
> Gruß
>
>
> Jens



-------------------------------------------------------
SF.Net email is sponsored by:
Tame your development challenges with Apache's Geronimo App Server. Download
it for free - -and be entered to win a 42" plasma tv or your very own
Sony(tm)PSP.  Click here to play: http://sourceforge.net/geronimo.php
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users