Announcement regarding Precise (12.04) support

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Announcement regarding Precise (12.04) support

Dakota Benjamin

Hello fellow devs,


Recent additions and improvements to the OpenDroneMap toolchain have caused some problems in the 12.04 build. We added Ceres Solver to bundler when we added OpenSfM as an alternative to the matching/bundling part of the toolchain, which required some libraries that were unavailable in the precise apt repositories. In the next few days, we will push blending to the texturing module, which requires OpenCV 2.4, also not available as a package in 12.04. OpenDroneMap is built on cutting-edge technology, so continuing to work in an environment that is not supported by those technologies will only hinder effective development. In light of this, we will be ceasing support for 12.04 from here on out. I believe the most recent commit that is completely 12.04 compatible is https://github.com/OpenDroneMap/OpenDroneMap/tree/57b3bfe3e34f77e546be0fd88c38d278a50ad277, which uses the perl control script.


If you would like to discuss these changes, please join in on our new gitter page: https://gitter.im/OpenDroneMap/OpenDroneMap


Thank you,

Dakota Benjamin



"It is not down in any map; true places never are."

      Herman Melville


_______________________________________________
OpenDroneMap-dev mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/opendronemap-dev