Announce QTiles plugin

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Announce QTiles plugin

Alexander Bruy
Hi all and sorry for cross-posting,

we (NextGIS) are pleased to announce QTiles plugin for QGIS.

QTiles designed to generate raster tiles from QGIS projects according
to the Slippy Map specification [0] and supports two output types:
directory and ZIP-archive.

You can get plugin from official repo (don't forget to enable
experimental plugins). Comments and bugreports are welcome.

Merry Christmas and happy New Year!

[0] http://wiki.openstreetmap.org/wiki/Slippy_map_tilenames

--
Alexander Bruy
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: [Qgis-developer] Announce QTiles plugin

giohappy

Wow, thanks for this very useful Christmas gift!
I'm gonna test it next days for a real application ;-)

giovanni

Sent from Nexus

Il giorno 26/dic/2012 14:25, "Alexander Bruy" <[hidden email]> ha scritto:
Hi all and sorry for cross-posting,

we (NextGIS) are pleased to announce QTiles plugin for QGIS.

QTiles designed to generate raster tiles from QGIS projects according
to the Slippy Map specification [0] and supports two output types:
directory and ZIP-archive.

You can get plugin from official repo (don't forget to enable
experimental plugins). Comments and bugreports are welcome.

Merry Christmas and happy New Year!

[0] http://wiki.openstreetmap.org/wiki/Slippy_map_tilenames

--
Alexander Bruy
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

magerlin
In reply to this post by Alexander Bruy
Hi

I see no Qtiles plugin in any repos (yes experimental plugins are enabled)?
Regards Morten

Currently using Qgis 3.10.0
Windows 10, 64bit
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

Alexander Bruy
Ensure that you have QGIS official repo [0] connected and experimental
plugins enabled

[0] http://plugins.qgis.org/plugins/plugins.xml

On Thu, 27 Dec 2012 01:59:42 -0800 (PST)
magerlin <[hidden email]> wrote:

> Hi
>
> I see no Qtiles plugin in any repos (yes experimental plugins are enabled)?
>
> -----
> Regards Morten
>
> Qgis 1.8.0 Stand alone installer in Win7 64 bit

--
Alexander Bruy
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

Andre Joost
Am 27.12.12 10:57, schrieb Alexander Bruy:
> Ensure that you have QGIS official repo [0] connected and experimental
> plugins enabled
>

you missed the essential part:
according to

> [0] http://plugins.qgis.org/plugins/plugins.xml

it is not available for:

>> Qgis 1.8.0 Stand alone installer in Win7 64 bit
>

HTH,
André Joost

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

Nathan Woodrow
If you don't have the official plugin repo in the plugin installer.  You just need to copy the link to the xml file and add it manually. 

- Nathan 

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

Andre Joost
Am 27.12.12 11:56, schrieb Nathan Woodrow:
> If you don't have the official plugin repo in the plugin installer.  You
> just need to copy the link to the xml file and add it manually.
>

Thats not the problem: You need Qgis master (1.9.0) to run the plugin.
Lisboa does not like it :-(

Greetings,
André Joost

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

Alexander Bruy
In reply to this post by Andre Joost
I didn't miss anything. Please read question carefully. Even QGIS
1.6.0 show this plugin in installer and allow to download it.

QGIS minimum version is another thing and not related to Plugin installer.

On Thu, 27 Dec 2012 11:52:10 +0100
Andre Joost <[hidden email]> wrote:

> you missed the essential part:
> according to
>
> > [0] http://plugins.qgis.org/plugins/plugins.xml
>
> it is not available for:
>
> >> Qgis 1.8.0 Stand alone installer in Win7 64 bit
> >
>
> HTH,
> André Joost


--
Alexander Bruy
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

Andre Joost
Am 27.12.12 12:14, schrieb Alexander Bruy:
> I didn't miss anything. Please read question carefully. Even QGIS
> 1.6.0 show this plugin in installer and allow to download it.
>
> QGIS minimum version is another thing and not related to Plugin installer.
>

I'm not sure about 1.6.0, but Lisboa does not show the plugins in the
list that require 1.9.0 (which makes sense). If I install it with master
on the same machine, it is marked as "invalid" when starting Lisboa again.

Greetings,
André Joost


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Announce QTiles plugin

macho
In reply to this post by Andre Joost
On 12/27/2012 12:05 PM, Andre Joost wrote:
> Am 27.12.12 11:56, schrieb Nathan Woodrow:
>> If you don't have the official plugin repo in the plugin installer.  You
>> just need to copy the link to the xml file and add it manually.
>>
>
> Thats not the problem: You need Qgis master (1.9.0) to run the plugin.
> Lisboa does not like it :-(
Hi!

I just think it uses functions that are only available in QGIS master -
therefore you have to either wait for the next release or compile master
yourself (or use one of the nightly builts).
I am also working on a plugin that uses new functions that are only
available in master - well .. thats development ;)

Hope to see a new version soon .. but regarding the bugtrackter there is
still some work to do ..
What about introducing a "bughunting weekend"? coordinated on IRC..

kind regards
Werner

_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: [Qgis-developer] Announce QTiles plugin

mirko
In reply to this post by giohappy
Thanks for the great news. I have just tried for a little scale range and it seems working very good. Next week i will test it with a real project and its entire range of scales..

Regards

Mirko
Reply | Threaded
Open this post in threaded view
|

Re: [Qgis-developer] Announce QTiles plugin

_iso9001_
This post has NOT been accepted by the mailing list yet.
Dear All,

Thank you for providing such a wonderful tool. I have tried and generated tiles easily. What I am missing a symbology. I could not find any symbology option and/or css file. Is there any plan in the near future to add symobology options?

BR