Ambigous FeatureTypes

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Ambigous FeatureTypes

dirk.thalheim

Hello list,

 

we want to implement a WFS providing FeatureTypes of an extended INSPIRE AdministrativeUnits-Theme. In the extended schema an elf-au:AdministrativeUnit FeatureType is defined, which extends the au:AdministrativeUnit with some properties.

 

There seems to be an issue with ambiguous (local) FeatureTypeNames. First of all when performing automatic FeatureTypeMapping from XML schemas, the extra properties of the extended FeatureType are not included in the mapping. We solved this by defining the mapping manually for the missing properties. But a more serious problem is when we want to request the extended FeatureType. It seems that deegree ignores the namespaces and returns only the base FeatureType.

 

I tried following:

-          GET …?service=WFS&request=GetFeature&version=2.0.0&typenames=elf-au:AdministrativeUnit -> returns au:AdministrativeUnit

-          GET …?service=WFS&request=GetFeature&version=2.0.0&typenames=elf-au:AdministrativeUnit&namespaces=xmlns(elf-au,http://www.locationframework.eu/schemas/AdministrativeUnits/1.0) -> returns au:AdministrativeUnit

-          POST with xmlns:elf-au declaration on different places -> returns au:AdministrativeUnit

-          Removing au:AdministrativeUnit from FeatureTypeMapping and then same requests as above -> “Cannot perform query on feature type '{http://inspire.ec.europa.eu/schemas/au/4.0}AdministrativeUnit'. Feature type is not mapped.”

 

Request to extra FeatureTypes which are declared in the schema extension are working.

 

Has anyone experienced similar issues? Is this a Bug?

 

Kind regards,

 

Dirk

 


------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
deegree-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/deegree-users