AW:Capabilities Hochladen klappt nicht

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

AW:Capabilities Hochladen klappt nicht

Michael Pfeiffer-2
Hallo Liste,
 
mich wuerde auch mal interessieren woran das liegen kann, ich habe naemlich mittlerweile das gleiche Problem. Eigentlich dachte ich ja ueber das Stadium sei ich raus...na ja.
Der Load Capabilities Befehl passt bei mir 100 %ig im Mapbender 2.1 funktionierts naemlich. Auch in der Version 2.2 habe ich schon WMS-Dienste hochgeladen, doch seit gestern abend geht das Ganze nicht mehr.
Verbindung zur Datenbank scheint da zu sein. Einloggen, GUI erzeugen, alles in Ordnung. 
Ich habe die Vermutung, dass das Ganze mit Postgre/ PostGis zusammenhaengt. Seitdem ich die Verbindung zur PostGis Datenbank hergestellt habe gibts Probleme mit dem Hochladen. Sowohl mit der SQL 4-Datenbank als auch mit der Postgre 8 klappts jetzt nicht mehr. Auch in die Datenbank wird nichts eingetragen.
 
Hier mal die Anzeige die kommt, wenn ich versuche Capabilities hochzuladen:
 
 
So siehts aus, wenn ich absichtlich eine falsche Eingabe mache (auch anders als normal):
 
file: http://lj1.kl.intra.arcadis.de/cgi-bin/mapserv.exe?map=C:/www/PostGis/Testw.map&REQUEST=GetCapabilities&SERVICE=wms&VERSION=1.1.1id: id_d41d8c
version:
title: MapServer Message
abstract:
maprequest:
capabilitiesrequest:
featureinforequest:
gui_wms_mapformat:
gui_wms_featureinfoformat:
gui_wms_exceptionformat:
gui_wms_epsg:
wms_srs:
gui_wms_visible: 1

id: parent: name: title: queryable: 0 minScale: 0 maxScale: 0
dataurl:
metadataurl:
layerstyle:
 
 
Im uebrigen habe ich anschlie?end auch jede Menge "Germany Layer" in meiner GUI, genau wie Markus.
 
Woran liegts? Ich bin echt ratlos mittlerweile.
 
Gruesse
 
Michael
 
Umgebung:MB 22, Postgre 8.0.1 inkl. PostGis bzw. Mysql 4.1, PHP 5.0.5, Mapserver 4.6, Apache 2.0.55

From: <schramm@o2...>
Capabilities Hochladen klappt nicht  
2005-11-13 11:21

Hallo Liste!
Wir haben gerade Mapbender 2.2. installiert und eigentlich klappt auch
alles ganz super, nur Capabilities Hochladen geht nicht richtig, obwohl
in der  php.ini allow_url_fopen auf ?on? gestellt ist.
Allerdings klappt es auch mit lokalen im Mapserver bereitgestellten WMS
nicht. Wenn man eine GUI ausw?hlt und die Capabilities hochl?d, erscheint
auch die (meiner Meinung nach richtige) Anzeige des Files. Es kommt auch
keine Fehlermeldung. Guckt man dann aber in der GUI nach, welche WMS zur
Verf?gung stehen, erscheint dort der WMS Germany ? egal welchen WMS man
eigentlich hochladen wollte. Mit der Folge, dass man nach ein paar Versuchen
5mal den WMS Germany hat, aber nicht den WMS, den man haben wollte.

Mapbender l?uft in folgender Umgebung:
PsostgreSQl 8.0 mit Postgis-Erweiterung
Mapserver4.4 und Apache 2.0.55
auf Windows2000

Vielen Dank f?r die Hilfe
Marcus

------------------------------------------------------- This SF.net email is sponsored by: Splunk Inc. Do you grep through log files for problems? Stop! Download the new AJAX search engine that makes searching your log files as easy as surfing the web. DOWNLOAD SPLUNK! http://ads.osdn.com/?ad_id=7637&alloc_id=16865&op=click _______________________________________________ Mapbender-users mailing list [hidden email] https://lists.sourceforge.net/lists/listinfo/mapbender-users
Reply | Threaded
Open this post in threaded view
|

Re: AW:Capabilities Hochladen klappt nicht

schramm.marcus
Hallo Liste!
Michael: danke für die Antwort. Ich dachte schon, ich wäre der Einzige,
der das Problem hat.
Mittlerweile habe ich versucht, das Ganze noch ein bisschen einzugrenzen:
Beim hochladen des WMS wird bei mir in der Datenbank in der Tabelle wms  
tatsächlich ein neuer wms angelegt, mit einer bestimmten wms_id (bspw. 23).
In allen anderen Tabellen, stimmt diese Id dann aber nicht mehr - hier
wird überall die Id bzw. fkey_wms_id von dem Germany WMS vergeben (bei mir:
893), obwohl die richtigen Eintragungen für den hochgeladenen WMS in die
Datenbank geschrieben werden.
Ich habe mal versucht, die ID's von Hand anzupassen und das klappt tatsächlich.  
Aber richtig kann die Vorgehensweise ja nicht sein ;-)))

Also, falls jemand eine Idee hat, woran das liegen kann...
Viele Grüße
Marcus

----Ursprüngliche Nachricht----
Von: [hidden email]
Datum: Nov 23, 2005 5:22:27 PM
An: [hidden email]
Betreff: [Mapbender-users] AW:Capabilities Hochladen klappt nicht

Hallo Liste,  mich wuerde auch mal interessieren woran das liegen kann, ich
habe naemlich mittlerweile das gleiche Problem. Eigentlich dachte ich ja
ueber das Stadium sei ich raus...na ja. Der Load Capabilities Befehl passt
bei mir 100 %ig im Mapbender 2.1 funktionierts naemlich. Auch in der Version
2.2 habe ich schon WMS-Dienste hochgeladen, doch seit gestern abend geht
das Ganze nicht mehr. Verbindung zur Datenbank scheint da zu sein. Einloggen,
GUI erzeugen, alles in Ordnung. Ich habe die Vermutung, dass das Ganze mit
Postgre/ PostGis zusammenhaengt. Seitdem ich die Verbindung zur PostGis
Datenbank hergestellt habe gibts Probleme mit dem Hochladen. Sowohl mit
der SQL 4-Datenbank als auch mit der Postgre 8 klappts jetzt nicht mehr.
Auch in die Datenbank wird nichts eingetragen.  Hier mal die Anzeige die
kommt, wenn ich versuche Capabilities hochzuladen:  file: http://lj1.kl.
intra.arcadis.de/cgi-bin/mapserv.exe?map=C:/www/PostGis/Test.map&REQUEST=GetCapabilities&SERVICE=wms&VERSION=1.1.1  
So siehts aus, wenn ich absichtlich eine falsche Eingabe mache (auch anders
als normal):  file: http://lj1.kl.intra.arcadis.de/cgi-bin/mapserv.exe?map=C:
/www/PostGis/Testw.map&REQUEST=GetCapabilities&SERVICE=wms&VERSION=1.1.1id:
id_d41d8c
version:
title: MapServer Message
abstract:
maprequest:
capabilitiesrequest:
featureinforequest:
gui_wms_mapformat:
gui_wms_featureinfoformat:
gui_wms_exceptionformat:
gui_wms_epsg:
wms_srs:
gui_wms_visible: 1
id: parent: name: title: queryable: 0 minScale: 0 maxScale: 0
dataurl:
metadataurl: layerstyle:   Im uebrigen habe ich anschließend auch jede
Menge "Germany Layer" in meiner GUI, genau wie Markus.  Woran liegts? Ich
bin echt ratlos mittlerweile.  Gruesse  Michael  Umgebung:MB 22, Postgre
8.0.1 inkl. PostGis bzw. Mysql 4.1, PHP 5.0.5, Mapserver 4.6, Apache 2.0.55

From: <schramm@o2...>
Capabilities Hochladen klappt nicht  
2005-11-13 11:21
Hallo Liste! Wir haben gerade Mapbender 2.2. installiert und eigentlich
klappt auch alles ganz super, nur Capabilities Hochladen geht nicht richtig,
obwohl in der php.ini allow_url_fopen auf „on“ gestellt ist. Allerdings
klappt es auch mit lokalen im Mapserver bereitgestellten WMS nicht. Wenn
man eine GUI auswählt und die Capabilities hochläd, erscheint auch die (meiner
Meinung nach richtige) Anzeige des Files. Es kommt auch keine Fehlermeldung.
Guckt man dann aber in der GUI nach, welche WMS zur Verfügung stehen, erscheint
dort der WMS Germany – egal welchen WMS man eigentlich hochladen wollte.
Mit der Folge, dass man nach ein paar Versuchen 5mal den WMS Germany hat,
aber nicht den WMS, den man haben wollte. Mapbender läuft in folgender Umgebung:
PsostgreSQl 8.0 mit Postgis-Erweiterung Mapserver4.4 und Apache 2.0.55 auf
Windows2000 Vielen Dank für die Hilfe Marcus
------------------------------------------------------- This SF.net email
is sponsored by: Splunk Inc. Do you grep through log files for problems?
Stop! Download the new AJAX search engine that makes searching your log
files as easy as surfing the web. DOWNLOAD SPLUNK! http://ads.osdn.com/?
ad_id=7637&alloc_id=16865&op=click _______________________________________________
Mapbender-users mailing list [hidden email] https:
//lists.sourceforge.net/lists/listinfo/mapbender-users



-------------------------------------------------------
This SF.net email is sponsored by: Splunk Inc. Do you grep through log files
for problems?  Stop!  Download the new AJAX search engine that makes
searching your log files as easy as surfing the  web.  DOWNLOAD SPLUNK!
<a href="http://ads.osdn.com/?ad_idv37&alloc_id865&op=click">http://ads.osdn.com/?ad_idv37&alloc_id865&op=click
_______________________________________________
Mapbender-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mapbender-users