7.9.dev: which wxPython versions supprted?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

7.9.dev: which wxPython versions supprted?

Rich Shepard
On my Slackware-14.2/x86_64 systems wxPython4-4.0.7.post2 is installed. When
I try to start grass79 -gui it fails with this error:
Starting GRASS GIS...
ERROR: wxGUI requires wxPython. No module named 'wx'
You can still use GRASS GIS modules in the command line or in Python.
ERROR: Error in GUI startup. See messages above (if any) and if necessary, please report this error to the GRASS developers.
On systems with package manager, make sure you have the right GUI package, probably named grass-gui, installed.
To run GRASS GIS in text mode use the --text flag.
Use '--help' for further options
      grass79 --help
See also: https://grass.osgeo.org/grass79/manuals/helptext.html
Exiting...

In ~/.bash_profile I
export GRASS_WXVERSION=4.0.7.post2

What wxPython version do I need to use with 7.9.svn?

Regards,

Rich

_______________________________________________
grass-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: 7.9.dev: which wxPython versions supprted?

Rich Shepard
> From [hidden email] Mon May 25 14:35:42 2020

Rich,

did you see
https://github.com/OSGeo/grass/issues/649
?

To which I responded,

> Nope. I'll grab wxPython-4.1.0 and see if it builds with the SBo script.

Here's the latest;

I'm moving this to the user mail list because I'm not subscribed to the dev
mail list.

I downloaded wxPython-7.1.0 source code, changed the version number in the
SlackBuilds.org (SBo) build script, and the build completed without errors
other than a couple of empty metadata files.

However, when I try to start 'grass79 -gui' it fails with these errors:

$ grass79 -gui
Starting GRASS GIS...

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:96:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:97:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:97:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:97:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:94:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:122:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:135:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:94:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:122:
'caret-color' is not a valid property name

(gis_set.py:20526): Gtk-WARNING **: Theme parsing error: <data>:1:135:
'caret-color' is not a valid property name
Traceback (most recent call last):
   File "/usr/local/grass79/gui/wxpython/gis_set.py", line 1148, in OnInit
     StartUp = GRASSStartup()
   File "/usr/local/grass79/gui/wxpython/gis_set.py", line 224, in __init__
     self._do_layout()
   File "/usr/local/grass79/gui/wxpython/gis_set.py", line 399, in _do_layout
     description=self.llocation)
   File "/usr/local/grass79/gui/wxpython/gis_set.py", line 376, in
layout_list_box
     border=1)
wx._core.wxAssertionError: C++ assertion "!(flags & wxALIGN_CENTRE_HORIZONTAL)"
failed at /tmp/SBo/wxPython-4.1.0/ext/wxWidgets/src/common/sizer.cpp(2106) in
DoInsert(): Horizontal alignment flags are ignored in horizontal sizers
OnInit returned false, exiting...
ERROR: Error in GUI startup. See messages above (if any) and if necessary,
please report this error to the GRASS developers.
On systems with package manager, make sure you have the right GUI package,
probably named grass-gui, installed.
To run GRASS GIS in text mode use the --text flag.
Use '--help' for further options
      grass79 --help
See also: https://grass.osgeo.org/grass79/manuals/helptext.html
Exiting...

Is this a grass issue or an SBo issue? If the latter I'll let the package
maintainer know and he'll probably have it fixed tomorrow.

Regards,

Rich
_______________________________________________
grass-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: 7.9.dev: which wxPython versions supprted?

Maris Nartiss
tl;dr Only master branch (7.9) has some wxPython-4.1 related fixes.
Unless you are ready to provide fixes, do not mix GRASS with wxPython
>4.0.

Māris.
_______________________________________________
grass-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-user
Reply | Threaded
Open this post in threaded view
|

Re: 7.9.dev: which wxPython versions supprted?

Rich Shepard
On Tue, 26 May 2020, Maris Nartiss wrote:

> tl;dr Only master branch (7.9) has some wxPython-4.1 related fixes. Unless
> you are ready to provide fixes, do not mix GRASS with wxPython
>> 4.0.

Māris,

I'm not sure that I'm following you. I'm building (and using) 7.9.dev, the
master branch, as indicated in the subject. There were issues with 4.0.6
that are supposed to be fixed in 4.1.0 which is why I upgraded.

Regards,

Rich
_______________________________________________
grass-user mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/grass-user