3d dependency

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

3d dependency

Andrea Antonello

Hi, I am trying to add a dependency to the 3d viewer module in my geopaparazzi plugin to add the worldwind libs for a small panel I have.

My assumption is that I need to add:

<depends plugin-name="org.gvsig.view3d.app" />

in my config.xml.

then in the plugin pom:

<!-- 3d -->
<dependency>
<groupId>org.gvsig</groupId>
<artifactId>org.gvsig.view3d.lib.api</artifactId>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.gvsig</groupId>
<artifactId>org.gvsig.view3d.swing.api</artifactId>
<scope>compile</scope>
</dependency>

and finally in the dependency management section of the parent pom the version number.

I looked for the current version in the 2.3.1 gvsig installation and I get: 1.1.0-SNAPSHOT

but teh last available version in the gvsig maven seems to be 1.0.23, so I add the following:

            <dependency>
                <groupId>org.gvsig</groupId>
                <artifactId>org.gvsig.view3d.lib.api</artifactId>
                <version>1.0.23</version>
            </dependency>
            <dependency>
                <groupId>org.gvsig</groupId>
                <artifactId>org.gvsig.view3d.swing.api</artifactId>
                <version>1.0.23</version>
            </dependency>

Is this the way to go?

Thanks,
Andrea

‚Äč

_______________________________________________
gvSIG-desktop-devel mailing list
http://joinup.ec.europa.eu/mailman/listinfo/gvsig-desktop-devel