3.8.x don't build

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

3.8.x don't build

pvalsecc
Hi,

Is it me or the 3.8.x branch (or the 3.8.0 tag for that matter) don't build?

I have the core tests failing on that:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils#0': Injection of autowired dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Does anyone have any idea how to fix that? How come 3.8.0 was released with the tests not running? How is that possible?

Thanks.


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: 3.8.x don't build

Francois Prunayre
Hi Patrick,

Le ven. 6 sept. 2019 à 14:41, Patrick Valsecchi <[hidden email]> a écrit :
Hi,

Is it me or the 3.8.x branch (or the 3.8.0 tag for that matter) don't build?

I have the core tests failing on that:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils#0': Injection of autowired dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Does anyone have any idea how to fix that?

Some investigations were done on my side but did not managed to solve that one so far...

 
How come 3.8.0 was released with the tests not running? How is that possible?

As discussed in your last post about "Test order", we have never been really confident with the results of some of the Java tests and some of us tried to fix those random errors (the actual one is BTW not random). I though you fixed execution by fixing the test order but it looks like it is not enough so you still have the error. We are probably missing Jesse who was providing good support on this type of issues and was following what was happening in core. We also have a couple of integration tests (probably not triggered much by people) and when making a release we also have a manual checklist.

So for sure this is an area where we can make significant progress but where we probably need some help and support. Working from time to time with Christophe, he has this test it first approach and know how to write and plug them quickly. So this can help all of us. Maybe we should share more experiences and organize some kind of training from time to time...

About 3.8.0, some of us have spent some time on testing and fixing blocking issues before making the release and after 2 days training this week, I did not find that much major issues.

Looking forward making progress on this topic! And solving that error.
 
 
Thanks.
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: 3.8.x don't build

pvalsecc
Hummmm. I didn't remember the quality of geonetwork being so bad :-(

OK, I'll give it a try.

On Fri, Sep 6, 2019 at 6:32 PM Francois Prunayre <[hidden email]> wrote:
Hi Patrick,

Le ven. 6 sept. 2019 à 14:41, Patrick Valsecchi <[hidden email]> a écrit :
Hi,

Is it me or the 3.8.x branch (or the 3.8.0 tag for that matter) don't build?

I have the core tests failing on that:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils#0': Injection of autowired dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Does anyone have any idea how to fix that?

Some investigations were done on my side but did not managed to solve that one so far...

 
How come 3.8.0 was released with the tests not running? How is that possible?

As discussed in your last post about "Test order", we have never been really confident with the results of some of the Java tests and some of us tried to fix those random errors (the actual one is BTW not random). I though you fixed execution by fixing the test order but it looks like it is not enough so you still have the error. We are probably missing Jesse who was providing good support on this type of issues and was following what was happening in core. We also have a couple of integration tests (probably not triggered much by people) and when making a release we also have a manual checklist.

So for sure this is an area where we can make significant progress but where we probably need some help and support. Working from time to time with Christophe, he has this test it first approach and know how to write and plug them quickly. So this can help all of us. Maybe we should share more experiences and organize some kind of training from time to time...

About 3.8.0, some of us have spent some time on testing and fixing blocking issues before making the release and after 2 days training this week, I did not find that much major issues.

Looking forward making progress on this topic! And solving that error.
 
 
Thanks.
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: 3.8.x don't build

pvalsecc
FYI, the tests are broken since faf26f7a32.

On Mon, Sep 9, 2019 at 8:44 AM Patrick Valsecchi <[hidden email]> wrote:
Hummmm. I didn't remember the quality of geonetwork being so bad :-(

OK, I'll give it a try.

On Fri, Sep 6, 2019 at 6:32 PM Francois Prunayre <[hidden email]> wrote:
Hi Patrick,

Le ven. 6 sept. 2019 à 14:41, Patrick Valsecchi <[hidden email]> a écrit :
Hi,

Is it me or the 3.8.x branch (or the 3.8.0 tag for that matter) don't build?

I have the core tests failing on that:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils#0': Injection of autowired dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Does anyone have any idea how to fix that?

Some investigations were done on my side but did not managed to solve that one so far...

 
How come 3.8.0 was released with the tests not running? How is that possible?

As discussed in your last post about "Test order", we have never been really confident with the results of some of the Java tests and some of us tried to fix those random errors (the actual one is BTW not random). I though you fixed execution by fixing the test order but it looks like it is not enough so you still have the error. We are probably missing Jesse who was providing good support on this type of issues and was following what was happening in core. We also have a couple of integration tests (probably not triggered much by people) and when making a release we also have a manual checklist.

So for sure this is an area where we can make significant progress but where we probably need some help and support. Working from time to time with Christophe, he has this test it first approach and know how to write and plug them quickly. So this can help all of us. Maybe we should share more experiences and organize some kind of training from time to time...

About 3.8.0, some of us have spent some time on testing and fixing blocking issues before making the release and after 2 days training this week, I did not find that much major issues.

Looking forward making progress on this topic! And solving that error.
 
 
Thanks.
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: 3.8.x don't build

Francois Prunayre
Not only. there is one failing in 0688311 - fixing it.

Le lun. 9 sept. 2019 à 08:47, Patrick Valsecchi <[hidden email]> a écrit :
FYI, the tests are broken since faf26f7a32.

On Mon, Sep 9, 2019 at 8:44 AM Patrick Valsecchi <[hidden email]> wrote:
Hummmm. I didn't remember the quality of geonetwork being so bad :-(

OK, I'll give it a try.

On Fri, Sep 6, 2019 at 6:32 PM Francois Prunayre <[hidden email]> wrote:
Hi Patrick,

Le ven. 6 sept. 2019 à 14:41, Patrick Valsecchi <[hidden email]> a écrit :
Hi,

Is it me or the 3.8.x branch (or the 3.8.0 tag for that matter) don't build?

I have the core tests failing on that:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils#0': Injection of autowired dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Does anyone have any idea how to fix that?

Some investigations were done on my side but did not managed to solve that one so far...

 
How come 3.8.0 was released with the tests not running? How is that possible?

As discussed in your last post about "Test order", we have never been really confident with the results of some of the Java tests and some of us tried to fix those random errors (the actual one is BTW not random). I though you fixed execution by fixing the test order but it looks like it is not enough so you still have the error. We are probably missing Jesse who was providing good support on this type of issues and was following what was happening in core. We also have a couple of integration tests (probably not triggered much by people) and when making a release we also have a manual checklist.

So for sure this is an area where we can make significant progress but where we probably need some help and support. Working from time to time with Christophe, he has this test it first approach and know how to write and plug them quickly. So this can help all of us. Maybe we should share more experiences and organize some kind of training from time to time...

About 3.8.0, some of us have spent some time on testing and fixing blocking issues before making the release and after 2 days training this week, I did not find that much major issues.

Looking forward making progress on this topic! And solving that error.
 
 
Thanks.
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: 3.8.x don't build

Francois Prunayre

Le lun. 9 sept. 2019 à 08:51, Francois Prunayre <[hidden email]> a écrit :
Not only. there is one failing in 0688311 - fixing it.

Le lun. 9 sept. 2019 à 08:47, Patrick Valsecchi <[hidden email]> a écrit :
FYI, the tests are broken since faf26f7a32.

On Mon, Sep 9, 2019 at 8:44 AM Patrick Valsecchi <[hidden email]> wrote:
Hummmm. I didn't remember the quality of geonetwork being so bad :-(

OK, I'll give it a try.

On Fri, Sep 6, 2019 at 6:32 PM Francois Prunayre <[hidden email]> wrote:
Hi Patrick,

Le ven. 6 sept. 2019 à 14:41, Patrick Valsecchi <[hidden email]> a écrit :
Hi,

Is it me or the 3.8.x branch (or the 3.8.0 tag for that matter) don't build?

I have the core tests failing on that:
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils#0': Injection of autowired dependencies failed; nested exception is org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.BeanCreationException: Could not autowire field: private org.fao.geonet.kernel.datamanager.IMetadataUtils org.fao.geonet.kernel.datamanager.base.BaseMetadataSchemaUtils.metadataUtils; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Caused by: org.springframework.beans.factory.NoSuchBeanDefinitionException: No qualifying bean of type [org.fao.geonet.kernel.datamanager.IMetadataUtils] found for dependency: expected at least 1 bean which qualifies as autowire candidate for this dependency. Dependency annotations: {@org.springframework.beans.factory.annotation.Autowired(required=true)}
Does anyone have any idea how to fix that?

Some investigations were done on my side but did not managed to solve that one so far...

 
How come 3.8.0 was released with the tests not running? How is that possible?

As discussed in your last post about "Test order", we have never been really confident with the results of some of the Java tests and some of us tried to fix those random errors (the actual one is BTW not random). I though you fixed execution by fixing the test order but it looks like it is not enough so you still have the error. We are probably missing Jesse who was providing good support on this type of issues and was following what was happening in core. We also have a couple of integration tests (probably not triggered much by people) and when making a release we also have a manual checklist.

So for sure this is an area where we can make significant progress but where we probably need some help and support. Working from time to time with Christophe, he has this test it first approach and know how to write and plug them quickly. So this can help all of us. Maybe we should share more experiences and organize some kind of training from time to time...

About 3.8.0, some of us have spent some time on testing and fixing blocking issues before making the release and after 2 days training this week, I did not find that much major issues.

Looking forward making progress on this topic! And solving that error.
 
 
Thanks.
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork


_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork