3.0 beta testing

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

3.0 beta testing

jmckenna
Administrator
Hi all,

I'm trying to get the 3.0 beta working with MS4W; I get a 404 error for
a missing "site.css" file, that is not included in either of the 3.0
beta packages posted on https://www.geomoose.org/download.html.

(I also get a blank map, but, I thought I'd start with the missing
site.css file)

Related question: a new MS4W is going out the door shortly, should the
installer also point to this GM3 beta?  (I was thinking to allow users
to install 2.9.3 or 3.0-beta).  Or, should I wait a bit until these
little issues are ironed out.  Let me know

thanks,

-jeff


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3.0 beta testing

Dan Little-2
Hey Jeff,

Can you checkout the quickstart? The site.css is intentionally not included as it's an "empty" target for people to drop in their own CSS.

Link to the quickstart: 

I suspect the blank map is because you're missing the *data* package.

To be honest, the code is pretty solid. When was your date for the MS4W release? I can probably have the short list of known bugs fixed by whenever that is.

-Duck

On Tue, Jul 11, 2017 at 2:52 PM, Jeff McKenna <[hidden email]> wrote:
Hi all,

I'm trying to get the 3.0 beta working with MS4W; I get a 404 error for a missing "site.css" file, that is not included in either of the 3.0 beta packages posted on https://www.geomoose.org/download.html.

(I also get a blank map, but, I thought I'd start with the missing site.css file)

Related question: a new MS4W is going out the door shortly, should the installer also point to this GM3 beta?  (I was thinking to allow users to install 2.9.3 or 3.0-beta).  Or, should I wait a bit until these little issues are ironed out.  Let me know

thanks,

-jeff


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc


_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3.0 beta testing

jmckenna
Administrator
Hey Ducky,

You're right, I didn't download the demo data.  Very nice document!
Will let you know how it goes here, following those steps.  Thanks!

-jeff



On 2017-07-11 4:54 PM, Dan Little wrote:

> Hey Jeff,
>
> Can you checkout the quickstart? The site.css is intentionally not
> included as it's an "empty" target for people to drop in their own CSS.
>
> Link to the quickstart:
> - https://theduckylittle.github.io/gm3/ms4w-quickstart/index.html
>
> I suspect the blank map is because you're missing the *data* package.
>
> To be honest, the code is pretty solid. When was your date for the MS4W
> release? I can probably have the short list of known bugs fixed by
> whenever that is.
>
> -Duck
>
> On Tue, Jul 11, 2017 at 2:52 PM, Jeff McKenna
> <[hidden email] <mailto:[hidden email]>>
> wrote:
>
>     Hi all,
>
>     I'm trying to get the 3.0 beta working with MS4W; I get a 404 error
>     for a missing "site.css" file, that is not included in either of the
>     3.0 beta packages posted on https://www.geomoose.org/download.html
>     <https://www.geomoose.org/download.html>.
>
>     (I also get a blank map, but, I thought I'd start with the missing
>     site.css file)
>
>     Related question: a new MS4W is going out the door shortly, should
>     the installer also point to this GM3 beta?  (I was thinking to allow
>     users to install 2.9.3 or 3.0-beta).  Or, should I wait a bit until
>     these little issues are ironed out.  Let me know
>
>     thanks,
>
>     -jeff
>
>
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3.0 beta testing

jmckenna
Administrator
In reply to this post by Dan Little-2
Works well with the data!  I'm going to add this to the installer today
or tomorrow morning.

I do see a msProjectRect() warning (in the Apache error log) when I
tried the Identify tool (I don't think this happened with 2.9.3) :

[Tue Jul 11 17:15:17.850862 2017] [cgi:error] [pid 5336:tid 1124]
[client 127.0.0.1:52058] AH01215: msProjectRect(): Warning: degenerate
rect
{-10371918.100936,5552707.780121,-10371918.100936,5552707.780121}\r:
C:/ms4w/Apache/cgi-bin/mapserv.exe, referer:
http://127.0.0.1/gm3/desktop/index.html

The identify result looked correct in the interface.

-jeff




On 2017-07-11 4:54 PM, Dan Little wrote:

> Hey Jeff,
>
> Can you checkout the quickstart? The site.css is intentionally not
> included as it's an "empty" target for people to drop in their own CSS.
>
> Link to the quickstart:
> - https://theduckylittle.github.io/gm3/ms4w-quickstart/index.html
>
> I suspect the blank map is because you're missing the *data* package.
>
> To be honest, the code is pretty solid. When was your date for the MS4W
> release? I can probably have the short list of known bugs fixed by
> whenever that is.
>
> -Duck
>
> On Tue, Jul 11, 2017 at 2:52 PM, Jeff McKenna
> <[hidden email] <mailto:[hidden email]>>
> wrote:
>
>     Hi all,
>
>     I'm trying to get the 3.0 beta working with MS4W; I get a 404 error
>     for a missing "site.css" file, that is not included in either of the
>     3.0 beta packages posted on https://www.geomoose.org/download.html
>     <https://www.geomoose.org/download.html>.
>
>     (I also get a blank map, but, I thought I'd start with the missing
>     site.css file)
>
>     Related question: a new MS4W is going out the door shortly, should
>     the installer also point to this GM3 beta?  (I was thinking to allow
>     users to install 2.9.3 or 3.0-beta).  Or, should I wait a bit until
>     these little issues are ironed out.  Let me know
>
>     thanks,
>
>     -jeff
>
>
>     _______________________________________________
>     geomoose-psc mailing list
>     [hidden email] <mailto:[hidden email]>
>     https://lists.osgeo.org/mailman/listinfo/geomoose-psc
>     <https://lists.osgeo.org/mailman/listinfo/geomoose-psc>
>
>


--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 3.0 beta testing

jmckenna
Administrator
Ticket filed for that warning: https://github.com/geomoose/gm3/issues/186

-jeff



On 2017-07-11 5:18 PM, Jeff McKenna wrote:

> Works well with the data!  I'm going to add this to the installer today
> or tomorrow morning.
>
> I do see a msProjectRect() warning (in the Apache error log) when I
> tried the Identify tool (I don't think this happened with 2.9.3) :
>
> [Tue Jul 11 17:15:17.850862 2017] [cgi:error] [pid 5336:tid 1124]
> [client 127.0.0.1:52058] AH01215: msProjectRect(): Warning: degenerate
> rect
> {-10371918.100936,5552707.780121,-10371918.100936,5552707.780121}\r:
> C:/ms4w/Apache/cgi-bin/mapserv.exe, referer:
> http://127.0.0.1/gm3/desktop/index.html
>
> The identify result looked correct in the interface.
>
> -jeff
>
>
>
>
> On 2017-07-11 4:54 PM, Dan Little wrote:
>> Hey Jeff,
>>
>> Can you checkout the quickstart? The site.css is intentionally not
>> included as it's an "empty" target for people to drop in their own CSS.
>>
>> Link to the quickstart:
>> - https://theduckylittle.github.io/gm3/ms4w-quickstart/index.html
>>
>> I suspect the blank map is because you're missing the *data* package.
>>
>> To be honest, the code is pretty solid. When was your date for the
>> MS4W release? I can probably have the short list of known bugs fixed
>> by whenever that is.
>>
>> -Duck
>>
>> On Tue, Jul 11, 2017 at 2:52 PM, Jeff McKenna
>> <[hidden email] <mailto:[hidden email]>>
>> wrote:
>>
>>     Hi all,
>>
>>     I'm trying to get the 3.0 beta working with MS4W; I get a 404 error
>>     for a missing "site.css" file, that is not included in either of the
>>     3.0 beta packages posted on https://www.geomoose.org/download.html
>>     <https://www.geomoose.org/download.html>.
>>
>>     (I also get a blank map, but, I thought I'd start with the missing
>>     site.css file)
>>
>>     Related question: a new MS4W is going out the door shortly, should
>>     the installer also point to this GM3 beta?  (I was thinking to allow
>>     users to install 2.9.3 or 3.0-beta).  Or, should I wait a bit until
>>     these little issues are ironed out.  Let me know
>>
>>     thanks,
>>
>>     -jeff
>>
_______________________________________________
geomoose-psc mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/geomoose-psc
Loading...