#2059: Bionic Rasterio support

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

#2059: Bionic Rasterio support

OSGeoLive
#2059: Bionic Rasterio support
-------------------------+---------------------------
 Reporter:  darkblueb    |      Owner:  osgeolive@…
     Type:  enhancement  |     Status:  new
 Priority:  normal       |  Milestone:  OSGeoLive12.0
Component:  OSGeoLive    |   Keywords:  python
-------------------------+---------------------------
 ```
 user@live12a:~/srcs$ sudo pip install --upgrade --upgrade-strategy=only-
 if-needed rasterio

 [sudo] password for user:  XXXXXX

 Collecting rasterio
   Downloading
 https://files.pythonhosted.org/packages/59/f7/040531ab12b4a4522b7fd99eec39258b78b82c67e3adcf81f25ee4a3e544/rasterio-0.36.0.tar.gz
 (1.2MB)
     100% |████████████████████████████████| 1.2MB 531kB/s
 Collecting affine (from rasterio)
   Downloading
 https://files.pythonhosted.org/packages/ab/9c/ae51e175215d2ea4d563207f11ba3fa6054668ceea8b44c4eaaeac8d627c/affine-2.2.0-py2.py3
 -none-any.whl
 Collecting click-plugins (from rasterio)
   Downloading
 https://files.pythonhosted.org/packages/77/05/da5c9e19457f20cadfe22c397cd3852577066066f63e40f2baa0831b1693
 /click-plugins-1.0.3.tar.gz
 Collecting cligj (from rasterio)
   Downloading
 https://files.pythonhosted.org/packages/e8/c1/d2a5a83f1bf59b820b5ffb0c63fc31d13279d7b985f260c1f8c5ca1693d0/cligj-0.4.0-py2
 -none-any.whl
 Requirement not upgraded as not directly required: enum34 in
 /usr/lib/python2.7/dist-packages (from rasterio) (1.1.6)
 Requirement not upgraded as not directly required: numpy in
 /usr/lib/python2.7/dist-packages (from rasterio) (1.13.3)
 Collecting snuggs (from rasterio)
   Downloading
 https://files.pythonhosted.org/packages/5c/20/0cdca0baf52e9fa58ee01230a06fa29a00225f7c80eb07b3d81c641dac91/snuggs-1.4.1-py2
 -none-any.whl
 Collecting click>=3.0 (from click-plugins->rasterio)
   Downloading
 https://files.pythonhosted.org/packages/34/c1/8806f99713ddb993c5366c362b2f908f18269f8d792aff1abfd700775a77/click-6.7-py2.py3
 -none-any.whl (71kB)
     100% |████████████████████████████████| 71kB 509kB/s
 Requirement not upgraded as not directly required: pyparsing in
 /usr/lib/python2.7/dist-packages (from snuggs->rasterio) (2.2.0)
 Installing collected packages: affine, click, click-plugins, cligj,
 snuggs, rasterio
   Running setup.py install for click-plugins ... done
   Running setup.py install for rasterio ... done
 Successfully installed affine-2.2.0 click-6.7 click-plugins-1.0.3
 cligj-0.4.0 rasterio-0.36.0 snuggs-1.4.1

 ```

--
Ticket URL: <https://trac.osgeo.org/osgeolive/ticket/2059>
OSGeoLive <http://live.osgeo.org/>
self-contained bootable DVD, USB thumb drive or Virtual Machine based on Lubuntu, that allows you to try a wide variety of open source geospatial software without installing anything.

_______________________________________________
osgeolive mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeolive
Reply | Threaded
Open this post in threaded view
|

Re: #2059: Bionic Rasterio support

OSGeoLive
#2059: Bionic Rasterio support
-------------------------+----------------------------
 Reporter:  darkblueb    |       Owner:  osgeolive@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  OSGeoLive12.0
Component:  OSGeoLive    |  Resolution:
 Keywords:  python       |
-------------------------+----------------------------

Comment (by Bas Couwenberg):

 RasterIO is packaged: https://tracker.debian.org/pkg/rasterio

--
Ticket URL: <https://trac.osgeo.org/osgeolive/ticket/2059#comment:1>
OSGeoLive <http://live.osgeo.org/>
self-contained bootable DVD, USB thumb drive or Virtual Machine based on Lubuntu, that allows you to try a wide variety of open source geospatial software without installing anything.

_______________________________________________
osgeolive mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeolive
Reply | Threaded
Open this post in threaded view
|

Re: #2059: Bionic Rasterio support

OSGeoLive
In reply to this post by OSGeoLive
#2059: Bionic Rasterio support
-------------------------+----------------------------
 Reporter:  darkblueb    |       Owner:  osgeolive@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  OSGeoLive12.0
Component:  OSGeoLive    |  Resolution:
 Keywords:  python       |
-------------------------+----------------------------

Comment (by darkblueb):

 Sean Gilles écrit:

 https://sgillies.net/2018/05/25/rasterio-1-0-b1.html

 https://github.com/mapbox/rasterio/issues/1306

--
Ticket URL: <https://trac.osgeo.org/osgeolive/ticket/2059#comment:2>
OSGeoLive <http://live.osgeo.org/>
self-contained bootable DVD, USB thumb drive or Virtual Machine based on Lubuntu, that allows you to try a wide variety of open source geospatial software without installing anything.

_______________________________________________
osgeolive mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeolive
Reply | Threaded
Open this post in threaded view
|

Re: #2059: Bionic Rasterio support

OSGeoLive
In reply to this post by OSGeoLive
#2059: Bionic Rasterio support
-------------------------+----------------------------
 Reporter:  darkblueb    |       Owner:  osgeolive@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  OSGeoLive12.0
Component:  OSGeoLive    |  Resolution:
 Keywords:  python       |
-------------------------+----------------------------

Comment (by kalxas):

 rasterio is already installed on the latest nightly.

 We should link rasterio to rio as suggested above.

--
Ticket URL: <https://trac.osgeo.org/osgeolive/ticket/2059#comment:6>
OSGeoLive <http://live.osgeo.org/>
self-contained bootable DVD, USB thumb drive or Virtual Machine based on Lubuntu, that allows you to try a wide variety of open source geospatial software without installing anything.

_______________________________________________
osgeolive mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeolive
Reply | Threaded
Open this post in threaded view
|

Re: #2059: Bionic Rasterio support

OSGeoLive
In reply to this post by OSGeoLive
#2059: Bionic Rasterio support
-------------------------+----------------------------
 Reporter:  darkblueb    |       Owner:  osgeolive@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  OSGeoLive12.0
Component:  OSGeoLive    |  Resolution:
 Keywords:  python       |
-------------------------+----------------------------

Comment (by johanvdw):

 I'll try making a rasterio 1.0 beta package for debian experimental.

 We could probably also make sure the rio command works for the Osgeo live
 build.

 We should probably consider this for debian as well as the current rio
 program is hardly used and orphaned (and has no upstream), and connects to
 a piece of archeohardware.

--
Ticket URL: <https://trac.osgeo.org/osgeolive/ticket/2059#comment:7>
OSGeoLive <http://live.osgeo.org/>
self-contained bootable DVD, USB thumb drive or Virtual Machine based on Lubuntu, that allows you to try a wide variety of open source geospatial software without installing anything.

_______________________________________________
osgeolive mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeolive
Reply | Threaded
Open this post in threaded view
|

Re: #2059: Bionic Rasterio support

OSGeoLive
In reply to this post by OSGeoLive
#2059: Bionic Rasterio support
-------------------------+----------------------------
 Reporter:  darkblueb    |       Owner:  osgeolive@…
     Type:  enhancement  |      Status:  new
 Priority:  normal       |   Milestone:  OSGeoLive12.0
Component:  OSGeoLive    |  Resolution:
 Keywords:  python       |
-------------------------+----------------------------

Comment (by darkblueb):

 COG Mailing list announces `rio-cogeo`


 {{{
 -- successful build log on alpha1 into ~/.local

 user@osgeolive:~/src$ git clone https://github.com/mapbox/rio-cogeo.git
 Cloning into 'rio-cogeo'...
 remote: Counting objects: 305, done.
 remote: Compressing objects: 100% (59/59), done.
 remote: Total 305 (delta 48), reused 79 (delta 32), pack-reused 205
 Receiving objects: 100% (305/305), 1.34 MiB | 449.00 KiB/s, done.
 Resolving deltas: 100% (167/167), done.
 user@osgeolive:~/src$ cd rio-cogeo/
 user@osgeolive:~/src/rio-cogeo$ ls
 LICENSE  README.rst  codecov.yml  requirements.txt  rio_cogeo/  setup.py
 tests/  tox.ini
 user@osgeolive:~/src/rio-cogeo$ less requirements.txt
 user@osgeolive:~/src/rio-cogeo$ python setup.py build
 Traceback (most recent call last):
   File "setup.py", line 2, in <module>
     from setuptools import setup, find_packages
 ImportError: No module named setuptools
 user@osgeolive:~/src/rio-cogeo$ sudo apt install python-setuptools
 Reading package lists... Done
 Building dependency tree
 Reading state information... Done
 Suggested packages:
   python-setuptools-doc
 The following NEW packages will be installed:
   python-setuptools
 0 upgraded, 1 newly installed, 0 to remove and 37 not upgraded.
 Need to get 329 kB of archives.
 After this operation, 1415 kB of additional disk space will be used.
 Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 python-setuptools
 all 39.0.1-2 [329 kB]
 Fetched 329 kB in 7s (50.2 kB/s)
 Selecting previously unselected package python-setuptools.
 (Reading database ... 234564 files and directories currently installed.)
 Preparing to unpack .../python-setuptools_39.0.1-2_all.deb ...
 Unpacking python-setuptools (39.0.1-2) ...
 Setting up python-setuptools (39.0.1-2) ...
 user@osgeolive:~/src/rio-cogeo$
 user@osgeolive:~/src/rio-cogeo$ ls
 LICENSE  README.rst  codecov.yml  requirements.txt  rio_cogeo/  setup.py
 tests/  tox.ini
 user@osgeolive:~/src/rio-cogeo$ python setup.py build
 /usr/lib/python2.7/dist-packages/setuptools/dist.py:397: UserWarning:
 Normalizing '1.0dev.1' to '1.0.dev1'
   normalized_version,
 running build
 running build_py
 creating build
 creating build/lib.linux-x86_64-2.7
 creating build/lib.linux-x86_64-2.7/rio_cogeo
 copying rio_cogeo/profiles.py -> build/lib.linux-x86_64-2.7/rio_cogeo
 copying rio_cogeo/cogeo.py -> build/lib.linux-x86_64-2.7/rio_cogeo
 copying rio_cogeo/__init__.py -> build/lib.linux-x86_64-2.7/rio_cogeo
 creating build/lib.linux-x86_64-2.7/rio_cogeo/scripts
 copying rio_cogeo/scripts/cli.py -> build/lib.linux-
 x86_64-2.7/rio_cogeo/scripts
 copying rio_cogeo/scripts/__init__.py -> build/lib.linux-
 x86_64-2.7/rio_cogeo/scripts
 user@osgeolive:~/src/rio-cogeo$ python setup.py install --help
 /usr/lib/python2.7/dist-packages/setuptools/dist.py:397: UserWarning:
 Normalizing '1.0dev.1' to '1.0.dev1'
   normalized_version,
 Common commands: (see '--help-commands' for more)

   setup.py build      will build the package underneath 'build/'
   setup.py install    will install the package

 Global options:
   --verbose (-v)  run verbosely (default)
   --quiet (-q)    run quietly (turns verbosity off)
   --dry-run (-n)  don't actually do anything
   --help (-h)     show detailed help message
   --no-user-cfg   ignore pydistutils.cfg in your home directory

 Options for 'install' command:
   --prefix                             installation prefix
   --exec-prefix                        (Unix only) prefix for platform-
                                        specific files
   --home                               (Unix only) home directory to
 install
                                        under
   --user                               install in user site-package
 '/home/user/.local/lib/python2.7/site-
                                        packages'
   --install-base                       base installation directory
 (instead of
                                        --prefix or --home)
   --install-platbase                   base installation directory for
                                        platform-specific files (instead of
 --
                                        exec-prefix or --home)
   --root                               install everything relative to this
                                        alternate root directory
   --install-purelib                    installation directory for pure
 Python
                                        module distributions
   --install-platlib                    installation directory for non-pure
                                        module distributions
   --install-lib                        installation directory for all
 module
                                        distributions (overrides --install-
                                        purelib and --install-platlib)
   --install-headers                    installation directory for C/C++
                                        headers
   --install-scripts                    installation directory for Python
                                        scripts
   --install-data                       installation directory for data
 files
   --compile (-c)                       compile .py to .pyc [default]
   --no-compile                         don't compile .py files
   --optimize (-O)                      also compile with optimization: -O1
 for
                                        "python -O", -O2 for "python -OO",
 and
                                        -O0 to disable [default: -O0]
   --force (-f)                         force installation (overwrite any
                                        existing files)
   --skip-build                         skip rebuilding everything (for
                                        testing/debugging)
   --record                             filename in which to record list of
                                        installed files
   --install-layout                     installation layout to choose
 (known
                                        values: deb, unix)
   --old-and-unmanageable               Try not to use this!
   --single-version-externally-managed  used by system package builders to
                                        create 'flat' eggs

 usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
    or: setup.py --help [cmd1 cmd2 ...]
    or: setup.py --help-commands
    or: setup.py cmd --help

 user@osgeolive:~/src/rio-cogeo$ python setup.py install --user
 /usr/lib/python2.7/dist-packages/setuptools/dist.py:397: UserWarning:
 Normalizing '1.0dev.1' to '1.0.dev1'
   normalized_version,
 running install
 running bdist_egg
 running egg_info
 creating rio_cogeo.egg-info
 writing requirements to rio_cogeo.egg-info/requires.txt
 writing rio_cogeo.egg-info/PKG-INFO
 writing top-level names to rio_cogeo.egg-info/top_level.txt
 writing dependency_links to rio_cogeo.egg-info/dependency_links.txt
 writing entry points to rio_cogeo.egg-info/entry_points.txt
 writing manifest file 'rio_cogeo.egg-info/SOURCES.txt'
 reading manifest file 'rio_cogeo.egg-info/SOURCES.txt'
 writing manifest file 'rio_cogeo.egg-info/SOURCES.txt'
 installing library code to build/bdist.linux-x86_64/egg
 running install_lib
 running build_py
 creating build/bdist.linux-x86_64
 creating build/bdist.linux-x86_64/egg
 creating build/bdist.linux-x86_64/egg/rio_cogeo
 creating build/bdist.linux-x86_64/egg/rio_cogeo/scripts
 copying build/lib.linux-x86_64-2.7/rio_cogeo/scripts/__init__.py ->
 build/bdist.linux-x86_64/egg/rio_cogeo/scripts
 copying build/lib.linux-x86_64-2.7/rio_cogeo/scripts/cli.py -> build/bdist
 .linux-x86_64/egg/rio_cogeo/scripts
 copying build/lib.linux-x86_64-2.7/rio_cogeo/__init__.py -> build/bdist
 .linux-x86_64/egg/rio_cogeo
 copying build/lib.linux-x86_64-2.7/rio_cogeo/cogeo.py -> build/bdist
 .linux-x86_64/egg/rio_cogeo
 copying build/lib.linux-x86_64-2.7/rio_cogeo/profiles.py -> build/bdist
 .linux-x86_64/egg/rio_cogeo
 byte-compiling build/bdist.linux-x86_64/egg/rio_cogeo/scripts/__init__.py
 to __init__.pyc
 byte-compiling build/bdist.linux-x86_64/egg/rio_cogeo/scripts/cli.py to
 cli.pyc
 byte-compiling build/bdist.linux-x86_64/egg/rio_cogeo/__init__.py to
 __init__.pyc
 byte-compiling build/bdist.linux-x86_64/egg/rio_cogeo/cogeo.py to
 cogeo.pyc
 byte-compiling build/bdist.linux-x86_64/egg/rio_cogeo/profiles.py to
 profiles.pyc
 creating build/bdist.linux-x86_64/egg/EGG-INFO
 copying rio_cogeo.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-
 INFO
 copying rio_cogeo.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg
 /EGG-INFO
 copying rio_cogeo.egg-info/dependency_links.txt -> build/bdist.linux-
 x86_64/egg/EGG-INFO
 copying rio_cogeo.egg-info/entry_points.txt -> build/bdist.linux-
 x86_64/egg/EGG-INFO
 copying rio_cogeo.egg-info/requires.txt -> build/bdist.linux-x86_64/egg
 /EGG-INFO
 copying rio_cogeo.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg
 /EGG-INFO
 zip_safe flag not set; analyzing archive contents...
 creating dist
 creating 'dist/rio_cogeo-1.0.dev1-py2.7.egg' and adding 'build/bdist
 .linux-x86_64/egg' to it
 removing 'build/bdist.linux-x86_64/egg' (and everything under it)
 Processing rio_cogeo-1.0.dev1-py2.7.egg
 Copying rio_cogeo-1.0.dev1-py2.7.egg to /home/user/.local/lib/python2.7
 /site-packages
 Adding rio-cogeo 1.0.dev1 to easy-install.pth file

 Installed /home/user/.local/lib/python2.7/site-
 packages/rio_cogeo-1.0.dev1-py2.7.egg
 Processing dependencies for rio-cogeo==1.0.dev1
 Searching for rasterio[s3]>=1.0b1
 Reading https://pypi.python.org/simple/rasterio/
 Downloading
 https://files.pythonhosted.org/packages/d1/46/405d3d6765519fce20e1f83b4bedd1f563c140d7b3d7111ce8506c9423a2/rasterio-1.0b1-cp27
 -cp27mu-
 manylinux1_x86_64.whl#sha256=455b5e82d362a9599574aab769c04de5ef426d65f0c241222fc26354965225fd
 Best match: rasterio 1.0b1
 Processing rasterio-1.0b1-cp27-cp27mu-manylinux1_x86_64.whl
 Installing rasterio-1.0b1-cp27-cp27mu-manylinux1_x86_64.whl to
 /home/user/.local/lib/python2.7/site-packages
 writing requirements to /home/user/.local/lib/python2.7/site-
 packages/rasterio-1.0b1-py2.7-linux-x86_64.egg/EGG-INFO/requires.txt
 Adding rasterio 1.0b1 to easy-install.pth file
 Installing rio script to /home/user/.local/bin

 Installed /home/user/.local/lib/python2.7/site-
 packages/rasterio-1.0b1-py2.7-linux-x86_64.egg
 Searching for boto3>=1.2.4
 Reading https://pypi.python.org/simple/boto3/
 Downloading
 https://files.pythonhosted.org/packages/2f/e0/b9e3b23e100e0df42d3646e1d126a0f5e3d738921be142a2f0133ed502a5/boto3-1.7.37-py2.py3
 -none-
 any.whl#sha256=09f6e6e76c368c650bbd7df72a9dbb66b1fdb4ae37baf28dd8525246a4d75dd4
 Best match: boto3 1.7.37
 Processing boto3-1.7.37-py2.py3-none-any.whl
 Installing boto3-1.7.37-py2.py3-none-any.whl to
 /home/user/.local/lib/python2.7/site-packages
 writing requirements to /home/user/.local/lib/python2.7/site-
 packages/boto3-1.7.37-py2.7.egg/EGG-INFO/requires.txt
 Adding boto3 1.7.37 to easy-install.pth file

 Installed /home/user/.local/lib/python2.7/site-
 packages/boto3-1.7.37-py2.7.egg
 Searching for attrs
 Reading https://pypi.python.org/simple/attrs/
 Downloading
 https://files.pythonhosted.org/packages/41/59/cedf87e91ed541be7957c501a92102f9cc6363c623a7666d69d51c78ac5b/attrs-18.1.0-py2.py3
 -none-
 any.whl#sha256=4b90b09eeeb9b88c35bc642cbac057e45a5fd85367b985bd2809c62b7b939265
 Best match: attrs 18.1.0
 Processing attrs-18.1.0-py2.py3-none-any.whl
 Installing attrs-18.1.0-py2.py3-none-any.whl to
 /home/user/.local/lib/python2.7/site-packages
 writing requirements to /home/user/.local/lib/python2.7/site-
 packages/attrs-18.1.0-py2.7.egg/EGG-INFO/requires.txt
 Adding attrs 18.1.0 to easy-install.pth file

 Installed /home/user/.local/lib/python2.7/site-
 packages/attrs-18.1.0-py2.7.egg
 Searching for s3transfer<0.2.0,>=0.1.10
 Reading https://pypi.python.org/simple/s3transfer/
 Downloading
 https://files.pythonhosted.org/packages/d7/14/2a0004d487464d120c9fb85313a75cd3d71a7506955be458eebfe19a6b1d/s3transfer-0.1.13-py2.py3
 -none-
 any.whl#sha256=c7a9ec356982d5e9ab2d4b46391a7d6a950e2b04c472419f5fdec70cc0ada72f
 Best match: s3transfer 0.1.13
 Processing s3transfer-0.1.13-py2.py3-none-any.whl
 Installing s3transfer-0.1.13-py2.py3-none-any.whl to
 /home/user/.local/lib/python2.7/site-packages
 writing requirements to /home/user/.local/lib/python2.7/site-
 packages/s3transfer-0.1.13-py2.7.egg/EGG-INFO/requires.txt
 Adding s3transfer 0.1.13 to easy-install.pth file

 Installed /home/user/.local/lib/python2.7/site-
 packages/s3transfer-0.1.13-py2.7.egg
 Searching for jmespath<1.0.0,>=0.7.1
 Reading https://pypi.python.org/simple/jmespath/
 Downloading
 https://files.pythonhosted.org/packages/b7/31/05c8d001f7f87f0f07289a5fc0fc3832e9a57f2dbd4d3b0fee70e0d51365/jmespath-0.9.3-py2.py3
 -none-
 any.whl#sha256=f11b4461f425740a1d908e9a3f7365c3d2e569f6ca68a2ff8bc5bcd9676edd63
 Best match: jmespath 0.9.3
 Processing jmespath-0.9.3-py2.py3-none-any.whl
 Installing jmespath-0.9.3-py2.py3-none-any.whl to
 /home/user/.local/lib/python2.7/site-packages
 Adding jmespath 0.9.3 to easy-install.pth file
 Installing jp.py script to /home/user/.local/bin

 Installed /home/user/.local/lib/python2.7/site-
 packages/jmespath-0.9.3-py2.7.egg
 Searching for botocore<1.11.0,>=1.10.37
 Reading https://pypi.python.org/simple/botocore/
 Downloading
 https://files.pythonhosted.org/packages/0b/97/60eba2ca866d346459bfb6f95ff5b2b611d7b1b844d0733acb436d59c893/botocore-1.10.37-py2.py3
 -none-
 any.whl#sha256=5ae7db25223c9d2c30e44781d48c9c3eab93019abef39e8c3f8784d0f63825c2
 Best match: botocore 1.10.37
 Processing botocore-1.10.37-py2.py3-none-any.whl
 Installing botocore-1.10.37-py2.py3-none-any.whl to
 /home/user/.local/lib/python2.7/site-packages
 writing requirements to /home/user/.local/lib/python2.7/site-
 packages/botocore-1.10.37-py2.7.egg/EGG-INFO/requires.txt
 Adding botocore 1.10.37 to easy-install.pth file

 Installed /home/user/.local/lib/python2.7/site-
 packages/botocore-1.10.37-py2.7.egg
 Searching for futures<4.0.0,>=2.2.0
 Reading https://pypi.python.org/simple/futures/
 Downloading
 https://files.pythonhosted.org/packages/2d/99/b2c4e9d5a30f6471e410a146232b4118e697fa3ffc06d6a65efde84debd0/futures-3.2.0-py2
 -none-
 any.whl#sha256=ec0a6cb848cc212002b9828c3e34c675e0c9ff6741dc445cab6fdd4e1085d1f1
 Best match: futures 3.2.0
 Processing futures-3.2.0-py2-none-any.whl
 Installing futures-3.2.0-py2-none-any.whl to
 /home/user/.local/lib/python2.7/site-packages
 Adding futures 3.2.0 to easy-install.pth file

 Installed /home/user/.local/lib/python2.7/site-
 packages/futures-3.2.0-py2.7.egg
 Searching for snuggs==1.4.1
 Best match: snuggs 1.4.1
 Adding snuggs 1.4.1 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for numpy==1.13.3
 Best match: numpy 1.13.3
 Adding numpy 1.13.3 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for enum34==1.1.6
 Best match: enum34 1.1.6
 Adding enum34 1.1.6 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for cligj==0.4.0
 Best match: cligj 0.4.0
 Adding cligj 0.4.0 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for click-plugins==1.0.2
 Best match: click-plugins 1.0.2
 Adding click-plugins 1.0.2 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for affine==2.1.0
 Best match: affine 2.1.0
 Adding affine 2.1.0 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for python-dateutil==2.6.1
 Best match: python-dateutil 2.6.1
 Adding python-dateutil 2.6.1 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Searching for docutils==0.14
 Best match: docutils 0.14
 Adding docutils 0.14 to easy-install.pth file

 Using /usr/lib/python2.7/dist-packages
 Finished processing dependencies for rio-cogeo==1.0.dev1
 }}}

--
Ticket URL: <https://trac.osgeo.org/osgeolive/ticket/2059#comment:8>
OSGeoLive <http://live.osgeo.org/>
self-contained bootable DVD, USB thumb drive or Virtual Machine based on Lubuntu, that allows you to try a wide variety of open source geospatial software without installing anything.

_______________________________________________
osgeolive mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/osgeolive